Статьи


23.02.2019

Объединение двух офисов по VPN на Mikrotik

Иногда возникает вопрос о том, как с помощью оборудования Mikrotik реализовать связь между двумя территориально разнесенными офисами так, что бы оба офиса были в одной локальной сети. В Интернете очень много инструкций на эту тему, но на наш взгляд есть способ гораздо проще. В этой статье расскажем самую простую схему реализации объединения двух и более офисов в единую локальную сеть с помощью VPN.

Для реализации нам понадобятся два маршрутизатора Mikrotik. Первый будет выступать в качестве VPN-сервера, а второй и, при необходимости, последующие в качестве VPN-клиентов. На самом деле реализовать можно не только с помощью VPN, но и L2TP и IP Sec, это не важно, главное понять принцип работы, а он очень простой. Мы будем работать с L2TP.

Настройка VPN-сервера

Итак, на первом микротике включаем VPN-сервер и добавляем клиента на вкладке Secrets:

/interface l2tp-server server
set authentication=mschap2 enabled=yes
/ppp secret
add local-address=192.168.0.1 name=office2 password=qwerty123! profile=default-encryption remote-address=192.168.0.2 service=l2tp

Теперь добавляем интерфейс сервера

/interface l2tp-server
add name=l2tp-in2 user=office2

На этом работа с первым микротиком у нас закончена. Маршрутизатор полностью готов к работе и приему соединений. Теперь приступаем к настройке клиентского оборудования.

Настройка VPN-клиента

Здесь еще проще, чем на первом. Переходим PPP->Interface->L2TP Client и вводим учетные данные, которые задали на первом микротике.

/interface l2tp-client
add allow=mschap2 connect-to-1.1.1.1 disabled=no name="Office 1" password=qwerty123 user=office2

*1.1.1.1 - это пример, Вам необходимо ввести IP адрес своего оборудования в офисе 1.

Второй маршрутизатор готов. Теперь осталось только добавить маршрут, что бы сотрудники Офиса 2 могли пользоваться Интернетом и внутренними ресурсами офиса 1. Для этого необходимо зайти в IP->Routes и добавить маршрут.

На маршрутизаторе первого офиса добавляем маршрут:

/ip route
add comment="route to Office 2" dst-address=192.168.20.0/24 gateway=192.168.0.2 pref-src=192.168.10.1

А на маршрутизаторе второго офиса добавляем маршрут до офиса 1

/ip route
add comment="route to Office 1" dst-address=192.168.10.0/24 gateway=192.168.0.1 pref-src=192.168.20.1

Примечание: при добавление маршрута можно не указывать pref-src, но лучше указать.

На этом настройка объединения двух офисов в единую локальную сеть закончена. Как видите, абсолютно ничего сложного, вся настройка занимает не более 20 минут.

Объединение двух офисов по VPN на Mikrotik

Иногда возникает вопрос о том, как с помощью оборудования Mikrotik реализовать связь между двумя территориально разнесенными офисами так, что бы оба офиса были в одной локальной сети. В Интернете очень много инструкций на эту тему, но на наш взгляд есть способ гораздо проще. В этой статье расскажем самую простую схему реализации объединения двух и более офисов в единую локальную сеть с помощью VPN.